
<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<!-- ad-related js -->
<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
<script src="/www/js/init_device.js"></script>
<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20180326113007"></script>
<script type="text/javascript">if(adLayer==null||adLayer=='undefined'){var adLayer=[];}adLayer["itemType"]="article";</script>
<script type="text/javascript">try{IDG.GPT.unitName="/8456/IDG.US_E_Infoworld.com";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.unitName=IDG.GPT.unitName+"/"+"cloud-computing_section";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}var global_ShowSuper=true;var global_ShowHero=false;var url=window.location.href;if(url.indexOf("?")>1){url=url.split('?')[0];}try{IDG.GPT.addTarget("URL",encodeURIComponent(url));}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("zone",'article/containers');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("channel",'containers,cloud-computing,application-development');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("articleId",'3265457');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("type",'analysis');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("typeId",'9');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("manufacturer",'microsoft');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("templateType",'article-default');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categoryIds",[4045,3255,3646]);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categorySlugs",['containers','cloud-computing','application-development']);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{if(null!=IDG.GPT.getQsVal("env")){IDG.GPT.addTarget("env",IDG.GPT.getQsVal("env").replace(/\W/g,""));}}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("author",'Matt Asay');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("page_type",'');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("insiderContent",'false');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}</script>
<script type="text/javascript"></script>
<script src="/www.idge/js/thm_pre.js?v=20180326113007"></script>
<script type="text/javascript">(function(){try{var proximic_data={"data":["300003","121100","112200","131100","131111","112202","240000","240002","240003","240004","240001","240005","240006","240007","240008","240009","240011","240012","240013","240014","240017","240015","240016","20f4sh","bkwp85","enwcef","w601py","bsuu95","x8eev1","ibwrkt","9v0tiu","ihhss6","m853gr","skl8g2","li8svo","wu9nfp","e2co9k","r03wnl","folvaf","6vexzx","0nr7l6","z7xuj9","pytywb","44ywyv","3i8pvm","rroqf7","xks7sj","yn3dkv","agtqg7","7grvv1","agt9m3","240saz","pcz604","itgwkk","n2qz3z","8hdk5f","500033","500037","500034","500035","500036","500220","500230","500233","500234","500226","500247","500238","500219","500218","500221","500223"]};IDG.GPT.addTarget("proximic",proximic_data.data);}catch(e){console.log("Error: "+e);}})();</script>
<script>var isMobile=(typeof IDG.DEVICE!=='undefined')?IDG.DEVICE.isMobile():false;try{IDG.GPT.addBiddingParams("yieldbotPsn",(isMobile?"00f7":"2e20"));IDG.GPT.addBiddingParams("appnexusPlacementId",(isMobile?"6451382":"6353032"));IDG.GPT.addBiddingParams("TriLiftPrefix","infoworld_ros_");}catch(e){console.log("Error in adding bidding params: "+e);}</script>
<script src="/www/js/ads/narf_prebid.js?v=20180326113007"></script>
<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
<script type="text/javascript" src="/www/js/ads/gpt_launcher.js"></script>
<!-- metas -->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Containers vs. serverless computing: Why to go serverless | InfoWorld</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="canonical" href="https://www.infoworld.com/article/3265457/containers/why-serverless-is-the-better-option-than-containers.html"/>
<meta itemprop="url" content="https://www.infoworld.com/article/3265457/containers/why-serverless-is-the-better-option-than-containers.html"/>
<meta name="description" content="Container technologies like Docker are very powerful, but require talent you can’t get. Serverless computing provides the same benefits—with talent you can actually get"/>
<meta name="DC.date.issued" content="2018-03-27T03:00-05:00"/>
<meta name="date" content="2018-03-27"/>
<link rel="amphtml" href="https://www.infoworld.com/article/3265457/containers/why-serverless-is-the-better-option-than-containers.amp.html"/>
<meta property="og:title" content="Containers vs. serverless computing: Why to go serverless">
<meta property="og:description" content="Container technologies like Docker are very powerful, but require talent you can’t get. Serverless computing provides the same benefits—with talent you can actually get">
<meta property="og:image" content="https://images.techhive.com/images/article/2017/03/cloud-data-binary-pixabay-100715337-large.3x2.jpg"/>
<meta property="og:image:width" content="700"/>
<meta property="og:image:height" content="467"/>
<meta itemprop="image" content="https://images.techhive.com/images/article/2017/03/cloud-data-binary-pixabay-100715337-large.3x2.jpg">
<meta itemprop="thumbnailURl" content="https://images.techhive.com/images/article/2017/03/cloud-data-binary-pixabay-100715337-large.3x2.jpg"/>
<link rel="image_src" href="https://images.techhive.com/images/article/2017/03/cloud-data-binary-pixabay-100715337-large.3x2.jpg"/>
<meta name="twitter:image" content="https://images.techhive.com/images/article/2017/03/cloud-data-binary-pixabay-100715337-large.3x2.jpg"/>
<meta property="og:type" content="article"/>
<meta name="author" content="Matt Asay">
<meta property="og:site_name" content="InfoWorld"/>
<meta property="fb:app_id" content="196366870381968"/>
<meta property="og:url" content="https://www.infoworld.com/article/3265457/containers/why-serverless-is-the-better-option-than-containers.html">
<!-- Use Twitter Summary Card with Large Image for articles and videos -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@infoworld">
<meta name="twitter:description" content="Container technologies like Docker are very powerful, but require talent you can’t get. Serverless computing provides the same benefits—with talent you can actually get">
<meta name="rating" content="General">
<meta name="robots" content="NOODP,NOYDIR"/>
<meta name="google-site-verification" content="RD0aa-ox1hse8Hjz2fU6KzOMnGyqLwYUv13rGucjtjA"/>
<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3"/>
<!-- Sailthru -->
<meta name="sailthru.tags" content="containers,cloud-computing,application-development,matt-asay,analysis,medium"/>
<meta name="sailthru.image.thumb" content="https://images.techhive.com/images/article/2017/03/cloud-data-binary-pixabay-100715337-small.jpg"/>
<meta name="sailthru.image.full" content="https://images.techhive.com/images/article/2017/03/cloud-data-binary-pixabay-100715337-large.3x2.jpg"/>
<meta name="sailthru.title" content="Skip containers and do serverless computing instead"/>
<meta name="sailthru.description" content="Container technologies like Docker are very powerful, but require talent you can’t get. Serverless computing provides the same benefits—with talent you can actually get"/>
<meta name="displaytype" content="article"/>
<meta name="source" content="infoworld"/>
<meta name="category" content="containers,cloud computing,software development"/>
<meta name="storytype" content="analysis"/>
<!-- pagination -->
<link id="mobile-size" rel="stylesheet" href="/www.idge/css/inline-header-mobile.css?v=20180326113007"/>
<script>if(window.matchMedia("(min-width: 768px)").matches){document.getElementById('mobile-size').insertAdjacentHTML('afterend','<link id="desktop-size" rel="stylesheet" href="/www.idge/css/inline-header.css?v=20180326113007" />');}</script>
<link rel="stylesheet" href="/www.idge.ifw/css/inline-header.css?v=20180326113007"/>
<!-- css -->
<link rel="stylesheet" href="/www.idge/css/normalize.css"/>
<link rel="stylesheet" href="/www.idge/css/prettify.css"/>
<link rel="stylesheet" href="/www.idge.ans/js/select2-3.5.0/select2.css"/>
<link rel="stylesheet" href="/www/css/article.css?v=20180326113007"/>
<link rel="stylesheet" href="/www.idge/css/insider-promo-styles.css?v=20180326113007"/>
<link rel="stylesheet" href="/www.idge/css/print.css" media="print"/>
<link rel="stylesheet" href="/www.idge.ifw/css/article.css?v=20180326113007"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css"/>
<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->
<script type="text/javascript" src="//fonts.staticworld.net/fmz2tqe.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<!--  fav and touch icons -->
<link rel="shortcut icon" type="image/x-icon" href="https://idge.staticworld.net/ifw/favicon.ico"/>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://idge.staticworld.net/ifw/IFW_logo_social_144x144.png"/>
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://idge.staticworld.net/ifw/IFW_logo_social_114x114.png"/>
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://idge.staticworld.net/ifw/IFW_logo_social_72x72.png"/>
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://idge.staticworld.net/ifw/IFW_logo_social_57x57.png"/>
<link rel="apple-touch-icon" href="https://idge.staticworld.net/ifw/IFW_logo_social_300x300.png"/>
<!-- LiveRamp Sources -->
<script type="text/javascript" src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
<script src="/www/js/utils/liveRamp.js"></script>
<!-- End of LiveRamp -->
<script src="/www.idge.ans/js/select2-3.5.0/select2.js"></script>
<script>$(document).ready(function(){$("select#country").select2({placeholder:"country",minimumResultsForSearch:Infinity,allowClear:true});$("#jobPosition").select2({placeholder:"position",minimumResultsForSearch:Infinity,allowClear:true});$("#jobFunction").select2({placeholder:"function",minimumResultsForSearch:Infinity,allowClear:true});$("#companySize").select2({placeholder:"company size",minimumResultsForSearch:Infinity,allowClear:true});$("#industry").select2({placeholder:"industry",minimumResultsForSearch:Infinity,allowClear:true});});</script>
<script>var brandCode="ifw";var brandName="InfoWorld";var regDebugLog=false;var regApiUrl="https://regdev.idge.int/api/";var tokenPrefix='www';var tokenSuffix='.com/insider/token?';var brandDomain=".infoworld.com";var insiderContentType="article";var notEmptyArticle=false;var notEmptyMediaResource=false;var isInsiderPremium=false;var isResourceInsiderPremium=false;regApiUrl="https://reg.idgenterprise.com/api/";regDebugLog=false;tokenPrefix="http://www";tokenSuffix="/insider/token";notEmptyArticle=true;</script>
<script src="/www/js/utils/alc_hashes.js"></script>
<script src="/www/js/insider/insider_reg_api.js?v=20180326113007"></script>
<script src="/www/js/insider/jquery.maskedinput-1.4.min.js"></script>
<script>$(document).ready(function(){if(typeof(IDG.insiderReg.readCookie('nsdr'))!=='undefined'){$('#welcome-message').show();IDG.insiderReg.personalize();}else{$('.signin-register').show();}});</script>
<!-- Begin Eloqua Tracking -->
<script type="text/javascript" src="/www/js/analytics/eloqua/elqCfg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqImg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqFCS.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqScr.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqIDG.js"></script>
<script type="text/javascript">IDG=window.IDG||{};IDG.PageInfo=IDG.PageInfo||{};IDG.PageInfo=function(){return{eloqua_type:"article",eloqua_topic:""};}();var elqCustomerGUID="";if(this.GetElqCustomerGUID&&typeof GetElqCustomerGUID==="function"){elqCustomerGUID=GetElqCustomerGUID();}IDG.Eloqua.invoke_flash();</script>
<!-- End Eloqua Tracking -->
<script type="text/javascript">var g_arrModules=new Array();</script>
<meta name="parsely-title" content="Skip containers and do serverless computing instead"/>
<meta name="parsely-link" content="https://www.infoworld.com/article/3265457/containers/why-serverless-is-the-better-option-than-containers.html"/>
<meta name="parsely-type" content="NewsArticle"/>
<meta name="parsely-image-url" content="https://images.techhive.com/images/article/2017/03/cloud-data-binary-pixabay-100715337-large.3x2.jpg"/>
<meta name="parsely-pub-date" content="2018-03-27T10:00:00Z"/>
<meta name="parsely-section" content="Containers"/>
<meta name="parsely-author" content="Matt Asay"/>
<meta name="parsely-tags" content="type: analysis,source: infoworld,original"/>
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
<script src="/www/js/ads/ads.js"></script>
<script>var insiderSignedIn=document.cookie.indexOf("nsdr")>-1;var dlJobFunction='';var dlJobPosition='';var dlIndustry='';if(insiderSignedIn){var insiderToken=IDG.insiderReg.readCookie("nsdr");var tokens=IDG.insiderReg.readCookieProperty(insiderToken);if(!(tokens['jobPosition']===undefined)){dlJobPosition=tokens['jobPosition'];}if(!(tokens['jobFunction']===undefined)){dlJobFunction=tokens['jobFunction'];}if(!(tokens['industry']===undefined)){dlIndustry=tokens['industry'];}}insiderSignedIn=insiderSignedIn.toString();var sincePublished='0 days';sincePublished=sincePublished.split(" ")[0];dataLayer=[{'articleId':'3265457','articleDisplayId':'1','articleTitle':'Skip containers and do serverless computing instead','articleType':'Analysis','audience':'enterprise','author':'Matt Asay','blogName':'','brandpost':'false','categoryIdList':'4045,3255,3646','categoryIdPrimary':'4045','contentStrategy':'','contentType':'analysis','datePublished':'2018-03-27','dateUpdated':'','daysSincePublished':sincePublished,'daysSinceUpdated':'','displayType':'article','environment':'production','ga_enabled':'true','gaTrackingId':'UA-6647659-1','geolocEnabled':'true','industry':dlIndustry,'insiderSignedIn':insiderSignedIn,'isBlog':'false','isInsiderContent':'false','isICN':'false','jobFunction':dlJobFunction,'jobPosition':dlJobPosition,'pageNumber':'1','parselyEnabled':'true','parselyDomain':'infoworld.com','platform':'Web','primaryCategory':'containers','primaryCategoryList':'containers,cloud computing,software development','property':'infoworld','propertyCountry':'US','purchaseIntent':'awareness','sailthruCustomerId':'15048a979f9e43e0bcdcd131b5cf2bcb','skimlinksId':'111346X1569476','source':'infoworld','sponsorName':'','tags':'','videoAutoplay':'false','articleHasVideo':'false'}];</script>
<script type="text/javascript">var _sf_async_config={};_sf_async_config.uid=29363;_sf_async_config.path="/article/3265457/containers/why-serverless-is-the-better-option-than-containers.html";_sf_async_config.title="Containers vs. serverless computing: Why to go serverless | InfoWorld";_sf_async_config.domain="infoworld.com";if(window.location.href.indexOf("video")&&true){_sf_async_config.playerdomain=_sf_async_config.domain.replace("www.","");}_sf_async_config.useCanonical=true;_sf_async_config.sections="containers";_sf_async_config.authors="Matt Asay";</script>
<script>var dataLayer=window.dataLayer=window.dataLayer||[];var adBlockStatus='false';function AdBlockEnabled(){var ad=document.createElement('ins');ad.className='AdSense';ad.style.display='block';ad.style.position='absolute';ad.style.top='-1px';ad.style.height='1px';if(document.body!=null){document.body.appendChild(ad);var isAdBlockEnabled=!ad.clientHeight;document.body.removeChild(ad);}return isAdBlockEnabled;}if(AdBlockEnabled()!=undefined){adBlockStatus=AdBlockEnabled().toString();}if(document.body==null){if(window.canRunAds===undefined){adBlockStatus='true';}else{adBlockStatus='false';}}dataLayer.push({'adBlockStatus':adBlockStatus});</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-5C7C8C" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-5C7C8C');</script>
<!-- End Google Tag Manager -->
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
</head>
<body id="article3265457" class="article infoworld">
<!-- Begin welcome ad overlay - gpt-overlay position  -->
<div id="superadunit" class="hidden">
<div class="ad">
<div class="ad-header">
<div class="brand-logo"></div>
<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
</div>
<div id="gpt-overlay" class=" ad-container">
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-overlay","true");IDG.GPT.displayGoogleTagSlot('gpt-overlay');</script>
</div>
</div>
</div>
<!--  End welcome ad overlay - gpt-overlay position -->
<!-- BEGIN PAGE HEADER -->
<header id="banner">
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.main-header').insertBefore($('#banner .ad'));}</script>
<div class="topics-wrap">
<section class="topics">
<nav id="scrollable">
<!-- blx4 #1064 blox4.raw_link_list  -->
<ul>
<li class="header">Trending<span class="colon">:</span></li>
<li><a href="/category/application-development/">Software Development</a></li>
<li><a href="/category/cloud-computing/">Cloud Computing</a></li>
<li><a href="/category/machine-learning/">Machine Learning</a></li>
<li><a href="/category/analytics/">Analytics</a></li>
<li><a href="/insider/">Insider Exclusives</a></li>
<li><a href="/resources/">Resources & White Papers</a></li>
<li><a href="/jobs">Job Search</a></li>
</ul>
</nav>
<div class="fading-gradient"></div>
<nav class="tools">
<ul class="user">
<li class="search-icon"><a href="#search" id="search-btn"><i class="ss-icon">Search</i></a></li>
</ul>
<ul class="social">
<li><a href="https://twitter.com/infoworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="https://www.linkedin.com/company/164364" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="https://www.facebook.com/InfoWorld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/100116140147692954063/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
<li><a href="/newsletters/signup.html"><i class="ss-icon ss-social-circle ss-mail"></i></a></li>
<li class="more-social"><i class="ss-icon ss-ellipsis"></i></li>
</ul>
</nav>
</section>
</div>
<div id="sticky-anchor"></div>
<section id="sticky-head" class="main">
<div class="wrapper">
<div class="masthead">
<button><i class="ss-icon ss-rows"></i></button>
<a href="/"><span class="ir logo">infoworld</span></a>
<!--
	            	<img class="print-only" src="/www.idge.ifw/images/infoworld-logo-print.png">
	            	-->
<img class="print-only" src="//idge.staticworld.net/ifw/infoworld-logo-print.png">
</div>
<div id="reading-tools-wrapper">
<nav class="tools">
<ul class="user">
</ul>
</nav>
</div>
<div class="insider-signin">
<span class="signin-register">
<a href="/learn-about-insider/"><span class="insider"></span></a> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> <span class="divider">|</span> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
</span>
<div id="welcome-message" class="insider-list">
<div id="insider-selector">
<div id="insider-welcome" class="label"></div>
<div class="stories">
<div class="personalization">Hi<span id="person-first-name"></span>! Here are the latest Insider stories.</div>
<ul>
<li><a href="/article/3265698/application-development/sony-s-latest-venture-helps-developers-actually-focus-on-software-development.html">Sony’s latest venture helps developers actually focus on software development</a></li>
<li><a href="/article/3264651/application-development/why-spectre-demands-more-elegantly-coded-software.html">Why Spectre demands more elegantly coded software</a></li>
<li><a href="/article/3264438/application-testing/how-to-use-moq-to-ease-unit-testing-in-c.html">How to use Moq to ease unit testing in C#</a></li>
<li><a href="/article/3257599/analytics/introducing-pandas-dataframe-for-python-data-analysis.html">Introducing Pandas DataFrame for Python data analysis</a></li>
</ul>
<div class="sign-out-link">
<a class="more-insider" href="/insider/">More Insider</a>
<a class="sign-out" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
</div>
</div>
</div>
</div>
</div>
<script>$('.signin-register').hide();$('#welcome-message').hide();</script>
</div>
</section>
<section class="tools-expand  ">
<form class="search" id="search-form" action="/search">
<label for="search-box">Search for</label>
<input type="text" name="query" id="banner-search-term" value="" class="searchbox-input-class"/>
<input type="submit" id="banner-search-submit" value="Go"/>
<input type="hidden" name="contentType" value="article,resource"/>
<div class="search-suggest">Suggestions for you</div>
</form>
<div class="user">
<form>
<label for="login-email">Insider email</label> <input id="login-email" type="text"/>
</form>
</div>
</section>
<div id="sticky-anchor-nav"></div>
<nav id="sticky-nav" class="main">
<ul class="topnav">
<li><a href="/category/analytics/" class="hasChildren">Analytics<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/analytics/">All Analytics</a></li>
<li><a href="/category/big-data/">Big Data</a></li>
<li><a href="/category/business-intelligence/">Business Intelligence</a></li>
</ul>
</li>
<li><a href="/category/it-careers/">Careers</a>
</li>
<li><a href="/category/cloud-computing/" class="hasChildren">Cloud Computing<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/cloud-computing/">All Cloud Computing</a></li>
<li><a href="/category/iaas/">IaaS</a></li>
<li><a href="/category/paas/">PaaS</a></li>
<li><a href="/category/saas/">SaaS</a></li>
</ul>
</li>
<li><a href="/category/collaboration/">Collaboration</a>
</li>
<li><a href="/category/containers/">Containers</a>
</li>
<li><a href="/category/data-center/" class="hasChildren">Data Centers<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/data-center/">All Data Centers</a></li>
<li><a href="/category/devops/">Devops</a></li>
<li><a href="/category/disaster-recovery/">Disaster Recovery</a></li>
<li><a href="/category/systems-management/">Systems Management</a></li>
</ul>
</li>
<li><a href="/category/database/" class="hasChildren">Databases<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/database/">All Databases</a></li>
<li><a href="/category/hadoop/">Hadoop</a></li>
<li><a href="/category/nosql/">NoSQL</a></li>
</ul>
</li>
<li><a href="/category/hardware/">Hardware</a>
</li>
<li><a href="/category/internet-of-things/">Internet of Things</a>
</li>
<li><a href="/category/machine-learning/">Machine Learning</a>
</li>
<li><a href="/category/mobile-technology/" class="hasChildren">Mobile<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/mobile-technology/">All Mobile</a></li>
<li><a href="/category/android/">Android</a></li>
<li><a href="/category/mobile-apps/">Mobile Apps</a></li>
<li><a href="/category/mobile-development/">Mobile Development</a></li>
<li><a href="/category/ios/">iOS</a></li>
</ul>
</li>
<li><a href="/category/networking/" class="hasChildren">Networking<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/networking/">All Networking</a></li>
<li><a href="/category/internet/">Internet</a></li>
<li><a href="/category/sdn/">SDN</a></li>
<li><a href="/category/wireless-local-area-network/">Wi-Fi</a></li>
</ul>
</li>
<li><a href="/category/open-source-tools/">Open Source</a>
</li>
<li><a href="/category/operating-systems/" class="hasChildren">Operating Systems<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/operating-systems/">All Operating Systems</a></li>
<li><a href="/category/linux/">Linux</a></li>
<li><a href="/category/mac-os-x/">MacOS</a></li>
<li><a href="/category/microsoft-windows/">Windows</a></li>
<li><a href="/category/windows-server/">Windows Server</a></li>
</ul>
</li>
<li><a href="/category/security/">Security</a>
</li>
<li><a href="/category/software/">Software</a>
</li>
<li><a href="/category/application-development/" class="hasChildren">Software Development<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/application-development/">All Software Development</a></li>
<li><a href="/category/java/">Java</a></li>
<li><a href="/category/javascript/">JavaScript</a></li>
<li><a href="/category/node-js/">Node.js</a></li>
</ul>
</li>
<li><a href="/category/storage/" class="hasChildren">Storage<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/storage/">All Storage</a></li>
<li><a href="/category/web-browsers/">Browsers</a></li>
<li><a href="/category/office-software/">Office Software</a></li>
</ul>
</li>
<li><a href="/category/virtualization/">Virtualization</a>
</li>
</ul>
<ul class="secondary">
<li><a href="/blogs">Blogs</a></li>
<li><a href="/reviews/">Reviews</a></li>
<li><a href="/insider/">Insider articles</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
<li><a href="/video/">Video</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
</ul>
</nav>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('div.insider-signin').prependTo('section.topics nav.tools');}</script>
<script>$(document).ready(function(){if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav ul li a.hasChildren").attr("href","#").addClass('notMobile');$('nav#sticky-nav ul.secondary').addClass('topnav');}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav#sticky-nav > ul").switchClass("topnav","primary");}});</script>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#sticky-anchor, section.main, section.topics, section.tools-expand, #sticky-anchor-nav, nav.main').insertBefore($('#banner .ad'));$(document).ready(function(){$('#banner section.tools-expand').addClass('top-margin');});}</script>
</header>
<script>$(document).ready(function(){$('body').addClass('insider-plus');var headerHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main.no-stick').css("top",headerHeight);if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main').height();stickyHeaderHeight=stickyHeaderHeight-8;}var supportsOrientationChange="onorientationchange"in window,orientationEvent=supportsOrientationChange?"orientationchange":"resize";if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<170){top=0;}else{top=top-50;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$thm.deviceHeight()<768){if($('html').hasClass('touch')){$('#insider-popup.modal-box .modal-body').addClass('short');}else{$('#insider-popup.modal-box .modal-body').addClass('short-desk');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<50){top=5;}else{top=top-40;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}var ua=navigator.userAgent.toLowerCase();var isAndroid=ua.indexOf("android")>-1;window.addEventListener(orientationEvent,function(){if(isAndroid&&(screen.width==600||screen.width==960)){location.reload(true);}},false);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.desktop)&&!$('html').hasClass('touch')){$("ul.social li.more-social").mouseenter(function(){$('ul.social > li').addClass('display-icon');});$("ul.social").mouseleave(function(){$('ul.social > li').removeClass('display-icon');});};if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$('html').hasClass('touch')){$("ul.social li.more-social").click(function(){$('ul.social > li').toggleClass('display-icon');});};$('.searchbox-input-class').each(function(){$(this).change(function(){var qStr=$(this).val();if($(this).val().indexOf('@')!=-1){qStr=qStr.replace(/@/g,' ');$(this).val(qStr);}});});});function sticky_relocate(){var headerHeight=$('header#banner').height();var winHeight=$(window).height();if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight-40;if(window.orientation==90||window.orientation==-90){winHeight=winHeight+50;}}else if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight+40;}else{winHeight=winHeight+10;}$('#banner nav#sticky-nav.main').css("height",winHeight);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top;if(window_top>div_top){$('#sticky-head').addClass('stick');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');}else{$('#sticky-head').removeClass('stick');$('#page-wrapper').removeClass('top-pad');$('#banner .ad').removeClass('top-margin');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('section.topics').addClass('stick-topics');$('#sticky-head').addClass('stick-head');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');$('#banner section.tools-expand').addClass('search');var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top+30;if(window_top>div_top){$('#sticky-head').addClass('stick');$('.topics.stick-topics, #search-form').addClass('remove');$('li.search-icon').fadeOut("fast");}else{$('#sticky-head').removeClass('stick');$('.topics.stick-topics, #search-form').removeClass('remove');$('li.search-icon').fadeIn("fast");}}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){if($('#sticky-head').hasClass('stick')){var stickyHeaderHeight=$('section.main').height();stickyHeaderHeight=52;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');$('#sticky-nav').removeClass('no-stick');}else{stickyHeaderHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').removeClass('stick');$('#sticky-nav').addClass('no-stick');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main.stick-head').height();stickyHeaderHeight=stickyHeaderHeight-8;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');if($('#sticky-head').hasClass('stick')){$('#sticky-head.stick').siblings('#sticky-nav').addClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').removeClass('no-stick');}else{$('#sticky-head').siblings('#sticky-nav').removeClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').addClass('no-stick');}}}$(function(){$(window).scroll(sticky_relocate);sticky_relocate();});</script>
<div id="insider-popup" class="modal-box ">
<div class="insider-modal-wrapper">
<div class="modal-header-title">
<div class="modal-banner-insider"><span class="insider"></span></div>
<div class="modal-close close">×</div>
</div>
<div class="modal-body">
<script>$(document).ready(function(){$('a[data-link]').click(function(){var dataLink=$(this).attr('data-link');var toKeep='div[data-link="'+dataLink+'"]';$('div[data-link]').not(toKeep).hide();if($(this).hasClass('link-transition')){$(toKeep).fadeIn(800);}else{$(toKeep).show();}return false;});});</script>
</div>
<div class="modal-footer">
<div class="modal-close close-btn">Close</div>
</div>
</div>
</div>
<script>$(document).ready(function(){var appendthis=("<div class='modal-overlay modal-close'></div>");if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').css({top:10,left:0});}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').height($(document).height());$('.modal-box').css('top','0');}var userAg=navigator.userAgent;$('a[data-modal-id]').click(function(e){e.preventDefault();$('body').append(appendthis);$('.modal-overlay').fadeTo(500,0.9);$('.modal-overlay').height($(document).height());var modalBox=$(this).attr('data-modal-id');if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$('#'+modalBox).fadeIn($(this).data());}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#'+modalBox).toggle('slide',{direction:'up'},800);}else{$('#'+modalBox).toggle('slide',{direction:'left'},600);}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("html, body").animate({scrollTop:0},700);$('a.btn.continue-on').click(function(){$('html, body').animate({scrollTop:0},500);});return false;}if(navigator.userAgent.match(/(iPad)/)){$("html, body").animate({scrollTop:0},500);}});$(".modal-close, .modal-overlay").click(function(){$('.select2-drop').css('display','none');$(".modal-overlay").fadeOut(500,function(){$(".modal-overlay").remove();});if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$(".modal-box").fadeOut(500);}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').toggle('slide',{direction:'up'},800);}else{$('.modal-box').toggle('slide',{direction:'left'},600);}}});});</script>
<!-- END PAGE HEADER -->
<div id="page-wrapper" class="page-wrapper">
<div id="skinAdTarget"></div>
<section role="main">
<article itemscope itemtype="http://schema.org/Article">
<div class="ticker-ad ad">
<div id="ticker" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("ticker","true");$('#ticker').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: ticker - [971 1115]");</script>
</div>
<!-- Events Header -->
<!-- //end Events Header -->
<header class='cat'>
<nav class="breadcrumbs horiz">
<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
<li><a href="/category/containers/" itemprop="url"><span itemprop="title">Containers</span></a></li>
</ul>
</nav>
<div class="category"></div>
<h1 itemprop="headline">Skip containers and do serverless computing instead</h1>
<section class="deck viewability">
<h3 itemprop="description">Container technologies like Docker are very powerful, but require talent you can’t get. Serverless computing provides the same benefits—with talent you can actually get</h3>
</section>
<div class="cat-social">
<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">
<li class="sosh">
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.infoworld.com%2Farticle%2F3265457%2Fcontainers%2Fwhy-serverless-is-the-better-option-than-containers.html&via=infoworld&text=Skip+containers+and+do+serverless+computing+instead" target="_blank" onclick="sharingTrack('Twitter-vert', 'twshare')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.infoworld.com%2Farticle%2F3265457%2Fcontainers%2Fwhy-serverless-is-the-better-option-than-containers.html" target="_blank" onclick="sharingTrack('Facebook-vert', 'fblike')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg"/>
</a>
</li>
<li class="sosh">
<a href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.infoworld.com%2Farticle%2F3265457%2Fcontainers%2Fwhy-serverless-is-the-better-option-than-containers.html&title=Skip+containers+and+do+serverless+computing+instead" target="_blank" onclick="sharingTrack('LinkedIn-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.infoworld.com%2Farticle%2F3265457%2Fcontainers%2Fwhy-serverless-is-the-better-option-than-containers.html" target="_blank" onclick="sharingTrack('GooglePlus-vert', 'googplus')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/gplus.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.infoworld.com%2Farticle%2F3265457%2Fcontainers%2Fwhy-serverless-is-the-better-option-than-containers.html&title=Skip+containers+and+do+serverless+computing+instead" target="_blank" onclick="sharingTrack('Reddit-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.infoworld.com%2Farticle%2F3265457%2Fcontainers%2Fwhy-serverless-is-the-better-option-than-containers.html" target="_blank" onclick="sharingTrack('ShareStumbleupPrint-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/stumbleupon.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="#email" id="email-icon">
<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg"/>
</a>
</li>
<li class="sosh hide print">
<a href="javascript:window.print();">
<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg"/>
</a>
</li>
<li class="more">
<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
</li>
</ul>
</div>
<script type="text/javascript">var isValidEmailAddress=isValidEmailAddress||function(emailAddress){var pattern=new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);return pattern.test(emailAddress);};function encodeQueryData(params){var ret=[];for(var paramKey in params){ret.push(encodeURIComponent(paramKey)+"="+encodeURIComponent(params[paramKey]));}return ret.join("&");}function bindEmailModal(){$('#emailModal').on("click",".close-btn",function(event){event.preventDefault();$('#emailModal').hide();$("#emailModal .eml-friend").show();$(".eml-friend-success").hide();$(".eml-friend-error").hide();$('#emailModal').fadeOut(200);$('#email-to').val('');$('#email-from').val('');$('#name').val('');$('#personalization').val('');$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");});$('#emailModal').on("submit","form",function(event){event.preventDefault();var $form=$(this);var action=$form.attr('action');var formData=$form.serialize();var emailFrom=$('#email-from').val();var emailTo=$('#email-to').val();var uresponse=$('#g-recaptcha-response').val();$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");if(isValidEmailAddress(emailFrom)&&isValidEmailAddress(emailTo)&&uresponse!=""){var eloquaParam={AssetCountforCurrentCampaign:"1",AssetName:"",AssetTopic:"",AssetType:"",BuyingCycle:"",C_Address1:"",C_Address2:"",C_BusPhone:"",C_City:"",C_Company_Size1:"",C_Country:"",C_EmailAddress:"",C_FirstName:"",C_Industry1:"",C_Job_Role1:"",C_LastName:"",C_State_Prov:"",C_Zip_Postal:"",ClientName:"",ProgramName:"",brand:"",elqFormName:"CentralRegistrationMasterForm",formId:"3062313",elqSiteId:1856,elqCustomerGUID:elqCustomerGUID,elqCookieWrite:0,friend_email:emailFrom,friend_article_title:"Skip containers and do serverless computing instead",friend_taxo:"Containers",friend_source:"InfoWorld",friend_article_url:"https://www.infoworld.com/article/3265457/containers/why-serverless-is-the-better-option-than-containers.html",device_platform:navigator.userAgent};$.ajax("https://secure.p01.eloqua.com/e/f2.aspx",{type:'GET',data:eloquaParam,success:function(data,textStatus,xhr){},error:function(xhr,textStatus,errorThrown){}});var eloquaParamMini={elqCustomerGUID:elqCustomerGUID,friend_taxo:"Containers",friend_source:"InfoWorld",device_platform:navigator.userAgent};formData+="&"+encodeQueryData(eloquaParamMini);$.ajax(action,{type:'POST',data:formData,success:function(data,textStatus,xhr){$("#emailModal .eml-friend").hide();$(".eml-friend-success").fadeIn(800);},error:function(xhr,textStatus,errorThrown){$("#emailModal .eml-friend").hide();$(".eml-friend-error").fadeIn(800);}});}else{if(uresponse==""){$('#eml-friend-captcha-message').html("Please verify you're not a robot!");}if(!isValidEmailAddress(emailTo)){$('#eml-to-address-message').html("Please enter a valid email address.");}if(!isValidEmailAddress(emailFrom)){$('#eml-from-address-message').html("Please enter a valid email address.");}}});}$(document).ready(function(){$(document).on("click","#email-icon",function(event){event.preventDefault();bindEmailModal();sharingTrack('Email-vert');$('#emailModal').fadeIn(800);});});</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">
<form class="eml-friend" action="/eloquaemail/article?eloqua=true&id=3265457">
<input type="hidden" name="title" value="Skip containers and do serverless computing instead"/>
<input type="hidden" name="url" value="https://www.infoworld.com/article/3265457/containers/why-serverless-is-the-better-option-than-containers.html"/>
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Email a friend</h3>
<div class="input-row">
<div id="eml-to-address-message" class="error-msg"></div>
<h4 class="input-label">To</h4>
<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
<p class="addl-text">Use commas to separate multiple email addresses</p>
</div>
<hr/>
<div class="input-row">
<div id="eml-from-address-message" class="error-msg"></div>
<h4 class="input-label">From</h4>
<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
</div>
<div class="input-row">
<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
</div>
<div class="input-row">
<textarea name="message" placeholder="Check out this article I found on InfoWorld." id="personalization" tabindex="4"></textarea>
</div>
<hr/>
<div class="input-row">
<div id="eml-friend-captcha-message" class="error-msg"></div>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<div class="g-recaptcha" data-sitekey="6LczmkcUAAAAANEO7J277KwH6Kzp6BEQjPTWP4S4"></div>
</div>
<hr/>
<div class="submit">
<input type="submit" value="Send" class="input-submit" tabindex="5">
<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
</div>
</form>
<div class="eml-ty eml-friend-success" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Thank you</h3>
<p class="msg-sent">Your message has been sent.</p>
</div>
<div class="eml-friend-error" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Sorry</h3>
<p class="msg-sent">There was an error emailing this page.</p>
</div>
</div>
</div>
<div class="cat byline vcard author with-image">
<div class="byline-wrapper">
<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
<a href="/author/Matt-Asay/" rel="author" title="Matt Asay"><img class="bylineImage  imgId100428566 " src="https://images.techhive.com/images/article/2014/09/mattasay_crop-100428566-byline.jpg" width="34" width="34" alt="Matt Asay" itemprop="image"/></a>
<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Matt-Asay/"><span itemprop="name">Matt Asay</span></a></span>
</p>
<p class="dateline">
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">InfoWorld</span><meta itemprop="logo" content="https://idge.staticworld.net/ifw/IFW_logo_social_300x300.png"/></span> <span class="divider">|</span>
<span class="pub-date" itemprop="datePublished" content="2018-03-27T03:00-0700">Mar 27, 2018
</span>
</p>
</div>
</div>
<div class="ad viewability">
<div id="topleaderboard" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("topleaderboard","true");$('#topleaderboard').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");</script>
</div>
</header>
<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
<meta itemprop="representativeOfPage" content="1"/>
<meta itemprop="height" content="394"/>
<meta itemprop="width" content="700"/>
<img src="https://images.techhive.com/images/article/2017/03/cloud-data-binary-pixabay-100715337-large.jpg" alt="Skip containers and do serverless computing instead" itemprop="contentUrl" itemprop="url"/>
<figcaption>
<span class="credit" itemprop="copyrightHolder">
<a href="https://pixabay.com/p-1892330/" target="_blank" rel="nofollow">Pete Linforth</a>
<a href="https://creativecommons.org/publicdomain/zero/1.0/" target="_blank" rel="nofollow">(CC0)</a>
</span>
</figcaption>
</figure>
<section class="epo cat-narrow" id="drr-top-ad">
<!-- Related -->
<div class="related-promo-wrapper">
<div class="promo apart">
<div class="hed">More like this</div>
<ul class="">
<li class="clearfix with-image">
<a href="/article/3265750/paas/serverless-in-the-cloud-aws-vs-google-cloud-vs-microsoft-azure.html"><img class="small.3x2Image  imgId100740709 " src="https://images.idgesg.net/images/article/2017/10/cloud_computing_metal_gears_hybrid_private_public_sealed_open_thinkstock_493269086_3x2-100740709-small.3x2.jpg" alt="cloud computing - metal gears - hybrid - private and public combination - sealed and open" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3265750/paas/serverless-in-the-cloud-aws-vs-google-cloud-vs-microsoft-azure.html">Serverless in the cloud: AWS vs. Google Cloud vs. Microsoft Azure</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3245925/cloud-computing/aws-cloud-services-guide-the-right-tools-for-the-job.html"><img class="small.3x2Image  imgId100677629 " src="https://images.techhive.com/images/article/2016/08/thinkstockphotos-459994091-100677629-small.3x2.jpg" alt="pixelated clouds reflecting on building windows" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3245925/cloud-computing/aws-cloud-services-guide-the-right-tools-for-the-job.html">AWS cloud services guide: The right tools for the job</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3245307/cloud-computing/in-2018-can-cloud-big-data-and-ai-stand-more-turmoil.html"><img class="small.3x2Image  imgId100691090 " src="https://images.techhive.com/images/article/2016/11/cloud_trends_2017-100691090-small.3x2.jpg" alt="cloud trends 2017" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3245307/cloud-computing/in-2018-can-cloud-big-data-and-ai-stand-more-turmoil.html">In 2018, can cloud, big data, and AI stand more turmoil?</a></div>
</div>
</li>
<li class="clearfix with-image">
<a class="play" href="/video/84915/tech-talk-the-coding-benefits-of-serverless-computing"><i class="ss-play"></i></a>
<a href="/video/84915/tech-talk-the-coding-benefits-of-serverless-computing"><img class="small.3x2Image  imgId100747812 " src="https://images.idgesg.net/images/article/2018/01/program-dirty-2018.01.25-11.10.07.00_00_13_22.still003-100747812-small.3x2.jpg" alt="program dirty 2018.01.25 11.10.07.00 00 13 22.still003" itemprop="image"/></a>
<div class="item">
<div class="item-eyebrow">Video</div>
<div class="title"><a href="/video/84915/tech-talk-the-coding-benefits-of-serverless-computing">Tech Talk: The coding benefits of serverless computing</a></div>
</div>
</li>
</ul>
</div>
</div>
<div class="ad top-ad">
<div id="topimu" class="adunit ad-container">
</div>
<script type="text/javascript">if($(window).width()>=930){IDG.GPT.addDisplayedAd("topimu","true");$('#topimu').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topimu - [971 1115]");}</script>
</div>
</section>
<section class="bodee">
<div class="ad placement">
<!--  Begin gpt-skin/inread -->
<div id="inread" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("inread","true");IDG.GPT.displayGoogleTagSlot('inread');</script>
<!--  End gpt-skin/inread -->
</div>
<script>var dataLayer=window.dataLayer=window.dataLayer||[];dataLayer.push({'event':'loadTopCollectionModule'});</script>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script type="text/javascript">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</script>
<div id="drr-container" class='cat ' itemprop="articleBody">
<p>Normally, mainstream enterprises are slow to embrace cutting-edge technologies, with startups and other early adopters setting the pace on everything from public cloud to <a href="https://www.infoworld.com/article/3240644/what-is-nosql-nosql-databases-explained.html">NoSQLs</a>. <a href="https://www.infoworld.com/article/3175761/serverless-computing-freedom-for-devs-at-last.html">Serverless computing</a>, however, just might be different.</p><p>Serverless, first popularized by <a href="https://www.infoworld.com/article/3263908/aws-lambda-tutorial-get-started-with-serverless-computing.html">AWS Lambda</a>, has seen “astonishing” growth of over 300 percent year over year, according to AWS chief Andy Jassy. Ironically, that growth may be driven by the “laggards,” as Redmonk analyst <a href="http://redmonk.com/jgovernor/2018/03/23/aws-lambda-driven-by-the-laggards/" rel="nofollow">James Governor calls them</a>, rather than the techno-hipsters.</p><aside class="fakesidebar"><strong>[ A developer’s guide: <a href="https://www.infoworld.com/article/3265750/paas/serverless-in-the-cloud-aws-vs-google-cloud-vs-microsoft-azure.html">Serverless: AWS vs. Google Cloud vs. Microsoft Azure</a>. | Then learn <a href="https://www.infoworld.com/article/3161191/paas/microsoft-azure-functions-locks-in-on-serverless-computing.html">how to use Microsoft’s Azure Functions</a> and <a href="https://www.infoworld.com/article/3263908/cloud-computing/aws-lambda-tutorial-get-started-with-serverless-computing.html">how to use AWS Lambda</a> for serverless computing. ]</strong></aside><h2>Containers are hot, but maybe not for you</h2><p>Over the last few years, nothing has been as hot as <a href="https://www.infoworld.com/article/3204171/what-is-docker-linux-containers-explained.html">containers</a>. Indeed, containers are so hot they’ve <a href="https://medium.com/@tdelvecchio/docker-scores-the-best-ever-net-score-in-etr-history-9e5887e3592b" rel="nofollow">broken the scale ETR uses</a> to measure CIO intent to purchase enterprise technology, registering “the strongest buying intention score ever recorded in [its] six-year history.” The reason is simple: Containers make developers much more productive. As Chenxi Wang <a href="https://www.infoworld.com/article/3204171/what-is-docker-linux-containers-explained.html">writes</a>, containers let developers “deploy, replicate, move, and back up a workload even more quickly and easily than you can do so using virtual machines.”</p><p>That’s big.</p><aside class="nativo-promo nativo-promo-1 smartphone" id=""> </aside><p>As great as they are, containers have a built-in deficiency: They’re not nearly easy enough, as Governor highlights:</p><p>Containers can help with IT cost reduction, but the main driver of adoption is velocity and the efficient management of infrastructure. The problem with container infrastructures is that this efficient management also calls for highly skilled developers and operators. Talent is a scarce resource. Even if you can afford the people, they may prefer to work for cooler companies.</p><p>“Cooler companies” refers to every company but yours. Not really, of course, but most large, successful enterprises may be cool with financial analysts but less so with developers. For these companies, serverless—the hottest thing since, well, containers—could be the answer.</p><h2>Serverless is cooler than cool in the mainstream</h2><p>“Serverless” refers to services like AWS Lambda that offer developers a way to focus on writing application logic rather than server infrastructure. Yes, this means a developer must trust that AWS, Microsoft, or Google get that infrastructure right, but the upside to embracing these cloud back ends is huge. As such, Stackery told Governor, “Serverless is being driven by mainstream enterprises. We see them leapfrogging containers so they can take something off the shelf and move quickly.”</p><aside class="nativo-promo nativo-promo-1 tablet desktop" id=""> </aside><p>In other words, they’d love to get into containers, but they may lack the expertise. So they’re borrowing that expertise from Amazon or another serverless vendor and skipping the container revolution.</p><p>For those enterprises less willing to trust their application infrastructure to a cloud vendor, some have hoped to bring serverless “in house,” running it on-premises in a corporate datacenter, just as some hope to ape the benefits of public cloud computing in so-called private clouds in their datacenters. It’s a nice theory. Unfortunately, it doesn’t work. Not for most companies, anyway.</p><p>Indeed, the minute that you bring serverless in house, you start to “negate the very advantage you started with,” <a href="https://twitter.com/mkosut/status/977592002563862528" rel="nofollow">argues AWS evangelist Mackenzie Kosut</a>. Instead, he says, companies should “spend more time on developing your application and business logic, less time managing systems.” Or, as AWS vice president of cloud architecture <a href="https://twitter.com/adrianco/status/977473923427139589" rel="nofollow">Adrian Cockcroft puts it</a>, if you “want to move quickly and cheaply,” you need to stop fixating on servers and instead entrust that to a cloud partner like AWS, Microsoft, or Google.</p><p>Of course, there will always be companies that want to get deep into their systems. For such companies, containers are revelatory in how much control and power they gain over their infrastructure.</p><p>Yet for most developers, <a href="https://twitter.com/PawelPabich/status/977397202262749185" rel="nofollow">contends Octopus engineer Pawel Pabich</a>, “containers are a distraction.” This is an amazing statement given how important containers have been. But it smells like truth. Developers are the new kingmakers, as the saying goes, but not everyone has the über-developers on their payroll necessary to tame containers to their needs. For such “laggards,” serverless will do just fine.</p>
<div class="end-note">
<!-- blx4 #2002 blox4.html  -->
<div id="" class="blx blxParticleendnote blxM2002  blox4_html  blxC24991"> </div>
</div>
</div>
<script>$("a[data-product-id]").on('click',function(e){var e=e||window.event;var dataLayer=window.dataLayer=window.dataLayer||[];var prodName=$(this).attr("data-product-name");prodName=prodName.replace("\\'","'");if($(this).parents('.slideshow').length>0){var productLinkPosition="Slideshow";}else if($(this).parents('.product-sb').length>0){var productLinkPosition="Product Sidebar";}else if($(this).parents('.at-a-glance.top').length>0){var productLinkPosition="AAG Top";}else if($(this).parents('.at-a-glance').length>0){var productLinkPosition="AAG Bottom";}else if($(this).parents('.product-chart').length>0){var productLinkPosition="Product Chart";}else if($(this).parents('.product-list').length>0){var productLinkPosition="Product List";}else{var productLinkPosition="Body Text";}dataLayer.push({'event':'affiliateLink','eventCategory':'Affiliate Link','eventAction':'Click','eventLabel':''+e.target+'','productVendor':$(this).attr("data-bkvndr"),'productManufacturer':$(this).attr("data-bkmfr"),'productName':prodName,'productId':$(this).attr("data-product-id"),'productLinkPosition':productLinkPosition});});</script>
<script>$("#drr-container a").on('click',function(e){var dataLayer=window.dataLayer=window.dataLayer||[];var $clickEl=$(this);var clickUrl=$clickEl.attr("href");var clickParentsUntilDrr=$clickEl.parentsUntil("#drr-container");var clickText=$clickEl.text().trim();var linkLocation;var linkType;var regex=new RegExp("cio|csoonline|computerworld|itnews|itworld|infoworld|networkworld|javaworld|techconnect|techhive|macworld|pcworld|greenbot|gamestar","i");if(clickParentsUntilDrr.hasClass("fakesidebar")){linkLocation="FSB";}else if(clickParentsUntilDrr.hasClass("end-note")){linkLocation="End Note";}else{linkLocation="Body";}if(regex.test(clickUrl)){linkType="Internal";}else{linkType="External";}dataLayer.push({'event':'editBodyLink','eventCategory':'Editorial Body Links','eventAction':linkType,'eventLabel':linkLocation+" | "+clickText+" | "+clickUrl});});</script>
<div class="apart-alt tags">
<span class="related">Related: </span>
<ul>
<li><a href="/category/containers">Containers</a></li>
<li><a href="/category/cloud-computing">Cloud Computing</a></li>
<li><a href="/category/application-development">Software Development</a></li>
</ul>
</div>
<div class="byline vcard author end-byline">
<div class="author-info">
<p class="bio">A longtime InfoWorld contributor and former intellectual property lawyer, Matt Asay is currently Head of Developer Ecosystem at Adobe at Adobe. The views expressed are his own and not that of his employer.</p>
</div><!-- end .author-info -->
<div class="brand-social">
<div class="follow-text">Follow</div>
<ul class="social-links">
<li>
<a href="/author/Matt-Asay/">
<i class="ss-icon ss-user"></i>
</a>
</li>
<li>
<a href="https://twitter.com/mjasay" class="twitter-follow" target="_blank">
<i class="ss-icon ss-social ss-twitter"></i>
</a>
</li>
<li>
<a href="https://www.linkedin.com/in/mjasay" class="linkedin-follow" target="_blank">
<i class="ss-icon ss-social ss-linkedin"></i>
</a>
</li>
<li>
<a href="/author/Matt-Asay/index.rss" class="rss">
<i class="ss-icon ss-social ss-rss"></i>
</a>
</li>
</ul>
</div>
</div>
<!-- blx4 #1172 blox4.html  -->
<div class="article-intercept">
<ul><li><a href="https://www.infoworld.com/newsletters/signup.html">Stay up to date with InfoWorld’s newsletters for software developers, analysts, database programmers, and data scientists</a>.</li><li><a href="https://www.infoworld.com/insider/">Get expert insights from our member-only Insider articles</a>.</li></ul>
</div>
<script src="/www/js/video/embedder.js"></script>
</section><!-- /.bodee -->
<div id="content-recommender" class="nolinks norewrite">
<div class="head">You Might Like</div>
<div id="rcjsload_e828b1"></div>
<script type="text/javascript">(function(){function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}}ad_block_test(function(is_blocked){var widget_id=30205;if(is_blocked===true){widget_id=30284;}var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);var rcel=document.createElement("script");rcel.id='rc_'+Math.floor(Math.random()*1000);rcel.type='text/javascript';rcel.src="//trends.revcontent.com/serve.js.php?w=30205&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth||document.documentElement.clientWidth)+"&referer="+referer+'&is_blocked='+is_blocked;rcel.async=true;var rcds=document.getElementById("rcjsload_e828b1");rcds.appendChild(rcel);});})();</script>
</div>
<div class="lazyload_ad">
<code type="text/javascript">
<!--
		document.write('<div id="ciu" class=" ad-container">');
		IDG.GPT.addDisplayedAd("ciu", "true");
		IDG.GPT.addLazyloadedAd("ciu", "true");
		document.write('</div>');
		$('#ciu').responsiveAd({screenSize:'971 1115', scriptTags: []});
		if (Object.keys(IDG.GPT.companions).length > 0 || IDG.GPT.disableInitialLoad) {
			IDG.GPT.refreshAd('ciu');
		}
		//-->
</code>
</div>
<link rel="stylesheet" href="/www.idge/css/sponsored-links.css?v=20180326113007"/>
<link rel="stylesheet" href="/www.idge.ifw/css/sponsored-links.css?v=20180326113007"/>
<section id="resources-sponsored-links">
<section class="sponsored-links">
<div class="head">Sponsored Links</div>
<ul class="first">
<li>
<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=4516344656&iu=/8456/IDG.US_E_InfoWorld.com" onclick="moduleTrack('Sponsored Links','resources-sponsored-links component')">
INSTANTLY dtSearch® TERABYTES of FILE+EMAIL+DB+WEB DATA; reviews & evals
</a>
</li>
</ul>
</section>
</section>
</article>
</section><!-- /role=main -->
</div><!-- /#page-wrapper -->
<link rel="stylesheet" href="/www.idge/css/foot.css?v=20180326113007"/>
<link rel="stylesheet" href="/www.idge.ifw/css/foot.css?v=20180326113007"/>
<footer>
<section class="brand" itemscope itemtype="http://schema.org/Organization">
<link itemprop="url" href="http://www.infoworld.com">
<a href="/"><span class="logo">InfoWorld</span></a>
<span class="tagline"> </span>
<span class="follow">
<label>Follow us</label>
<ul>
<li><a href="https://twitter.com/infoworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="https://www.linkedin.com/company/164364" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="https://www.facebook.com/InfoWorld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/100116140147692954063/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
<li><a href="/newsletters/signup.html"><i class="ss-icon ss-social-circle ss-mail"></i></a></li>
</ul>
</span>
</section>
<section class="topics">
<nav id="ft1">
<ul>
<li><a href="/category/analytics/">Analytics</a>
</li>
<li><a href="/category/it-careers/">Careers</a>
</li>
<li><a href="/category/cloud-computing/">Cloud Computing</a>
</li>
<li><a href="/category/collaboration/">Collaboration</a>
</li>
<li class="selected"><a href="/category/containers/" class="active">Containers</a>
</li>
<li><a href="/category/data-center/">Data Centers</a>
</li>
<li><a href="/category/database/">Databases</a>
</li>
<li><a href="/category/hardware/">Hardware</a>
</li>
<li><a href="/category/internet-of-things/">Internet of Things</a>
</li>
<li><a href="/category/machine-learning/">Machine Learning</a>
</li>
<li><a href="/category/mobile-technology/">Mobile</a>
</li>
<li><a href="/category/networking/">Networking</a>
</li>
<li><a href="/category/open-source-tools/">Open Source</a>
</li>
<li><a href="/category/operating-systems/">Operating Systems</a>
</li>
<li><a href="/category/security/">Security</a>
</li>
<li><a href="/category/software/">Software</a>
</li>
<li><a href="/category/application-development/">Software Development</a>
</li>
<li><a href="/category/storage/">Storage</a>
</li>
<li><a href="/category/virtualization/">Virtualization</a>
</li>
</ul>
</nav>
<nav id="ft2">
<ul>
<li><a href="/news">News</a></li>
<li><a href="/blogs">Blogs</a></li>
<li><a href="/reviews">Reviews</a></li>
<li><a href="/insider">Insider</a></li>
<li><a href="/resources">Resources</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
</ul>
</nav>
</section>
<section class="about">
<div class="wrapper">
<nav class="tertiary" id="ft3">
<ul>
<li><a href="/about/about.html">About Us</a>
<li><a href="/about/contactus.html">Contact</a>
<li><a href="/about/privacy.html">Privacy Policy</a>
<li><a href="https://www.idgenterprise.com/reach/infoworld/" target="_blank" rel="nofollow">Advertising</a>
<li><a href="https://www.idg.com/work-here/" target="_blank" rel="nofollow">Careers at IDG</a>
<li><a href="/about/adchoices.html">Ad Choices</a>
<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a>
</ul>
</nav>
</div>
</section>
<section class="copyright">
<div class="wrapper">
<p><a href="/about/copyright.html">Copyright</a> &copy; 2018 IDG Communications, Inc.</p>
<div class="network">
<div id="network-selector">
<div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
<ul>
<li><a href="https://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
<li><a href="https://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
<li><a href="https://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
<li><a href="https://www.gamestar.com" target="_blank" rel="nofollow">GameStar</a></li>
<li><a href="https://www.greenbot.com" target="_blank" rel="nofollow">Greenbot</a></li>
<li><a href="https://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
<li><a href="https://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
<li><a href="https://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
<li><a href="https://www.idgtechnetwork.com" target="_blank" rel="nofollow">IDG TechNetwork</a></li>
<li><a href="https://www.idg.tv" target="_blank" rel="nofollow">IDG.TV</a></li>
<li><a href="https://www.idgventures.com" target="_blank" rel="nofollow">IDG Ventures</a></li>
<li><a href="https://www.infoworld.com" target="_blank" rel="nofollow">Infoworld</a></li>
<li><a href="https://www.itnews.com" target="_blank" rel="nofollow">IT News</a></li>
<li><a href="https://www.itwhitepapers.com" target="_blank" rel="nofollow">ITwhitepapers</a></li>
<li><a href="https://www.itworld.com" target="_blank" rel="nofollow">ITworld</a></li>
<li><a href="https://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
<li><a href="https://www.linuxworld.com" target="_blank" rel="nofollow">LinuxWorld</a></li>
<li><a href="https://www.macworld.com" target="_blank" rel="nofollow">Macworld</a></li>
<li><a href="https://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
<li><a href="https://www.pcworld.com" target="_blank" rel="nofollow">PCWorld</a></li>
<li><a href="https://www.techconnect.com" target="_blank" rel="nofollow">TechConnect</a></li>
<li><a href="https://www.techhive.com" target="_blank" rel="nofollow">TechHive</a></li>
</ul>
</div><!-- /#network-selector -->
</div><!-- /.network -->
</div><!-- /.wrapper -->
</section>
</footer>
<script src="/www/js/analytics/mouse_down.js"></script>
<script src="/www/js/jquery/jquery-ui.js"></script>
<script src="/www/js/jquery/jquery.dfp.min.js"></script>
<script src="/www.idge/js/mule/shortstack_nav.js"></script>
<div id="mobilewelcomead" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("mobilewelcomead","true");$('#mobilewelcomead').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");</script>
<script src="/www/js/analytics/tracking.js"></script>
<script src="/www/js/autocomplete.js"></script>
<script src="/www.idge/js/social_sidecar.js"></script>
<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js"></script>
<script src="/www.idge/js/article.js?v=20180326113007"></script>
<script src="/www/js/prettify.js"></script>
<script src="/www.idge/js/jquery/responsive-tables.js"></script>
<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>$(document).ready(function(){$("table.tablesorter").tablesorter({widgets:['zebra']});$("table.tablesorter tbody tr").hover(function(){$(this).toggleClass("selected");});$("table.tablesorter thead tr th").each(function(){if($(this).find('.ss-icon').length<1){$(this).append('<i class="ss-icon"></i>');}});});</script>
<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script src="/www.idge/js/global.js?v=20180326113007"></script>
<script src="/www/js/webfonts/ss-social.js"></script>
<script src="/www/js/webfonts/ss-standard.js"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>
<!-- Begin BlueKai Tag -->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js"></script>
<script type="text/javascript">bk_allow_multiple_calls=true;var blueKaiId=14345;var blueKaiPort=10;var brandCode="ifw";var regUrl="https://regdev.idge.int/api/"
var daysToRefresh=30;var bk_debug_log=false;regUrl="https://reg.idgenterprise.com/api/";daysToRefresh=30;if(typeof(s)!='undefined'){bk_addPageCtx("pageType",(typeof(s.pageType)!='undefined')?s.pageType:'');}bk_addPageCtx("cmscatids","[4045,3255,3646]");bk_addPageCtx("cmpy","[]");bk_addPageCtx('tid','9');bk_addPageCtx("purchaseintent","awareness");params=getUrlParams('phint');if(Object.keys(params).length>0){bk_addPageCtx("idg_eid",params['idg_eid']);bk_addPageCtx("newt",params['newt']);bk_addPageCtx("isnl","1");}try{IDG.bkCoreApi.start();}catch(e){bk_doJSTag(blueKaiId,blueKaiPort);if(window.console&&window.console.log){window.console.log("Error Occured While Processing Profile Siubmission")}}$('article, #slideshowCarousel').on('click','.product-list-price, .btn-amazon, .productLink',function(e){var $linkEl=$(e.target);var po=$linkEl.data('po');if($.inArray(po,['amazon','vendor','other'])>=0){if(po=='amazon'){var prCat=$linkEl.data('bkc');if(typeof prCat!='undefined'){bk_addPageCtx('event','AmazonClick'+prCat);}bk_addPageCtx('event','AmazonClickContainers');bk_addPageCtx('event','AmazonClickCloudComputing');bk_addPageCtx('event','AmazonClickSoftwareDevelopment');}var prMfr=$linkEl.data('bkmfr');if(typeof prMfr!='undefined'){bk_addPageCtx('event','eCommerceMFR'+prMfr);}var prVndr=$linkEl.data('bkvndr');if(typeof prVndr!='undefined'){bk_addPageCtx('event','eCommerceClickVendor'+prVndr);}bk_doJSTag(34202,1);}});</script>
<!-- End BlueKai Tag -->
<div id="catfish" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("catfish","true");$('#catfish').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: catfish - [971 1115]");</script>
<!--  Begin gpt-skin/inread -->
<div id="gpt-skin" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-skin","true");IDG.GPT.displayGoogleTagSlot('gpt-skin');</script>
<!--  End gpt-skin/inread -->
<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>
<script type="text/javascript">$("div.lazyload_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});</script>
<script type='text/javascript'>g_arrModules['']=true;g_arrModules['Article Detail:Top:Breadcrumb']=true;g_arrModules['Article Detail:Social Sharing Vertical']=true;g_arrModules['']=true;g_arrModules['']=true;$('#resources-sponsored-links').addClass('show');</script>
<!-- Begin comScore Tag -->
<script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"6035308",c3:"",c5:"Containers",c6:"Article: Analysis",c15:"3265457"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1"/>
</noscript>
<!-- End comScore Tag -->
<script language="JavaScript" type="text/javascript">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</script>
<!-- SiteCatalyst code version: H.26.2.
Copyright 1996-2013 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->
<script language="JavaScript" type="text/javascript" src="/www.idge/js/analytics/s_code.js"></script>
<script language="JavaScript" type="text/javascript" id="omniVars">g_sOmnitureReportSuite=typeof g_sOmnitureReportSuite!='undefined'&&g_sOmnitureReportSuite?g_sOmnitureReportSuite:"infoworld-production";s.pageName="InfoWorld:article:analysis:Containers:3265457:Skip containers and do serverless computing instead";s.pageType="";if(typeof omnitureChannel!='undefined'){s.channel=omnitureChannel;}s.prop1="source:infoworld";s.eVar1="D=c1";s.prop2="content type:analysis";s.eVar2="D=c2";s.prop3="display type:article:analysis";s.eVar3="D=c3";s.prop4="0 days";s.eVar4="D=c4";s.prop6="";s.prop7="";s.eVar7="D=c7";s.prop9="category:containers";s.eVar9="D=c9";s.prop11="published:27-Mar-18";s.eVar11="D=c11";s.prop12="aid:3265457";s.eVar12="D=c12";s.prop13="";s.eVar13="D=c13";s.prop14="author:matt asay";s.eVar14="D=c14";s.prop15="page number:1";s.eVar15="D=c15";s.prop17="uri:/article/3265457/containers/why-serverless-is-the-better-option-than-containers.html";s.eVar17="D=c17";s.prop18="";s.eVar18="D=c18";s.prop24=getLoginStatusForOmniture();s.eVar24="D=c24";s.prop28=getTrackingToken('tk')?"tokens:"+getTrackingToken('tk'):"";s.eVar28="D=c28";s.prop37="rpn:ifw:analysis:infoworld:article:analysis:containers:3265457:skip containers and do serverless computing instead";s.eVar37="D=c37";s.prop39="";s.eVar39="D=c39";s.prop40="";try{s.prop41=IDG.GPT.getDisplayedAds(',')+','+IDG.GPT.getOtherAds(',');s.prop42=IDG.GPT.getModules(',');s.eVar42="D=c42";}catch(e){console.log("error in setting omniture vars: "+e);}s.prop53="4045";s.eVar53="D=c53";s.prop54="containers,cloud computing,software development";s.eVar30="D=c54";s.eVar33=s.prop55="4045,3255,3646";s.eVar33="D=c55";s.prop56="";s.eVar40="D=c56";s.prop61="";s.eVar10="D=c61";s.prop63="awareness";s.prop74="";s.eVar58="D=c74";s.prop75="";s.eVar60="D=c75";s.prop58=":";s.eVar59="D=c58";var sModules='';for(var i in g_arrModules){if(g_arrModules[i]&&i!=''){sModules+=i+',';}}sModules=sModules.replace(/,$/,'');s.prop42=sModules;s.eVar42="D=c42";s.events="";s.events=s.apl(s.events,'event33',',');s.eVar41="27-Mar-18";s.list3=s.prop42+","+s.eVar42;for(var p in s){if(s[p]&&p.match(/^(prop|ceVar)\d+$/)){s[p]=s[p].toLowerCase();}}s.campaign=s.getQueryParam('cid');var s_code=s.t();if(s_code)document.write(s_code)</script>
<script language="JavaScript" type="text/javascript">if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')</script><noscript><img src="http://idgenterprise.d1.sc.omtrdc.net/b/ss/infoworld-production/1/H.25--NS/0" height="1" width="1" border="0" alt=""/></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.26.2. -->
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
<span id="parsely-cfg" data-parsely-site="infoworld.com"></span>
</div>
<script>(function(s,p,d){var h=d.location.protocol,i=p+"-"+s,e=d.getElementById(i),r=d.getElementById(p+"-root"),u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net":"static."+p+".com";if(e)return;e=d.createElement(s);e.id=i;e.async=true;e.src=h+"//"+u+"/p.js";r.appendChild(e);})("script","parsely",document);</script>
<!-- END Parse.ly Include: Standard -->
<script type="text/javascript">$thm.logPlEvent({"b":"ifw","e":"view","t":"article","id":"3265457"});</script>
<div id="loginModal"></div>
<div id="logoffModal"></div>
<script type="text/javascript">a=top;f=self;if(a!=f){a.location=f.location;}</script>
</body>
</html>