Labyrinth of aggravation

In theory, it was simple. An older Compaq Proliant 1600R server with a Compaq SmartArray 221 RAID controller destined to be upgraded from Win2K/Exchange2K to Win2K3/Exchange2K3. Another Exchange server was brought up, mailboxes were moved, and we were ready to rebuild the original box. Oh, and we needed to expand the array on the SmartArray to pull the hotspare and make it an array member since we needed the spa

In theory, it was simple. An older Compaq Proliant 1600R server with a Compaq SmartArray 221 RAID controller destined to be upgraded from Win2K/Exchange2K to Win2K3/Exchange2K3. Another Exchange server was brought up, mailboxes were moved, and we were ready to rebuild the original box. Oh, and we needed to expand the array on the SmartArray to pull the hotspare and make it an array member since we needed the space. Should be a quickie. Three hours later, Windows 2003 is finally installing.

The problem? HP does not provide SmartStart CDs as downloadable ISOs, nor do they provide a boot CD or floppy that will recognize and configure a SmartArray 221 controller. ACUXE doesn't support the 221, and ACU v1.20A and B are boot floppies, but won't recognize the 221. We had a SmartStart CD, v.6.30, but it doesn't support the Proliant 1600 server. ACU v2.00+ is a Windows executable only, and the version installed on the existing Windows installation was v2.90. When we attempted to reconfigure the array with that utility, it errored with a "This controller doesn't have battery backup, so you can't make this change" dialog. Forget about the chicken and the egg, we're into multiple dimensions of Denver omlette.

Of course, this all happens between 10pm and 1am, so the lack of sleep is adding to the frustration. Neither of which can even approach the sheer madness caused by attempting to navigate HPs support site for any useful information whatsoever. Compaq^H^H^H^H^HHP engineered their servers and certain components -- such as this RAID controller -- to require software intervention to accomplish tasks that would normally be handled in the BIOS or in firmware. 99% of all RAID controllers have a hotkey configuration utility available at POST, and Compaq's more recent RAID controllers have this feature. The fact that the older controllers do not is a major problem for folks trying to work with that hardware, especially if they've misplaced the SmartStart CD and had any problems with the server that impacted the array controller.

So, how did we fix this? Compaq's ACU v2.80 doesn't have the same error checks that are found in v2.90. Note that this information does not exist in any form on HP's site. It was by pure frustration that we even tried backing off a version to v2.80. That version actually let us reconfigure the array while running under the OS installed on the array. Needless to say, Windows lost it's mind immediately following the reconfiguration, but we had indeed rebuilt the array, and could now install Windows 2003.

Hey, HP. Provide SmartStart CDs as ISO images. Maybe not the most recent version if you really want to sell it for $21.95, but at least the legacy versions. If we had a SmartStart CD v5.50, or access to an ISO, I'd be asleep now.

Mobile Security Insider: iOS vs. Android vs. BlackBerry vs. Windows Phone
Recommended
Join the discussion
Be the first to comment on this article. Our Commenting Policies