Backward compatibility questions arise in Android upgrade

Older devices might present issues, so developers should test their apps on every version of Android they wish to support

Although the newly released Google Android 1.5 software development kit offers such features as speech recognition, developers must be aware of backward compatibility issues on older devices, according to the Google Android blog.

Android features the company's software stack for mobile devices. With Android 1.5 SDK, released Monday, developers must ponder whether to allow an application to work on all devices or just those running newer software. "In some cases, it will be useful to employ the newer APIs on devices that support them while continuing to support older devices," the blog, posted by Andy McFadden, a Google software engineer, said.

[ When it comes to actual handsets running Android, there's been more talk than action. ]

If a new API is integral to a program, developers should add a manifest entry to ensure an application will not be installed on older devices. Developers need to test applications on every version of the Android framework expected to support it. "By definition, the behavior of your application will be different on each. Remember the mantra: If you haven't tried it, it doesn't work," McFadden states.

Release 1.5 allows developers to test for backward compatibility by specifying AVD (Android Virtual Devices) with different API levels. AVD enables better modeling of actual devices and makes it easier to work with multiple emulators running concurrently.

Once AVDs are created, developers can test an application with old and new versions of the system and can run them side-by-side.

Also featured in 1.5 are support for add-ons, which extend the SDK to access one or more external Android libraries, and an Eclipse ADT (Android development tools) plug-in featuring wizards for building Android-specific projects. Easier profiling of performance also is featured.

Tools and documentation are provided to to migrate applications developed on the Android 1.1 SDK. Android 1.5 SDK will not support the Zilog Z80 processor architecture. The kit is accessible on the Android Developers site.

Google plans to discuss Android 1.5 at the Google I/O conference in San Francisco in late May.

Join the discussion
Be the first to comment on this article. Our Commenting Policies