Firefox: In with the new, out with the compatibility

Endless parade of updates adds no visible benefit to users but breaks common functions like TinyMCE

Another day, another version of Firefox -- like rival Google has done with Chrome, Mozilla has put Firefox on an endless update cycle, with new versions every six weeks or so. Unlike the case with Chrome, compatibility issues seems to be the price to be paid for having Firefox's version number change so often, with no obvious beneficial changes in exchange.

For example, the new Firefox 11 breaks compatibility with older versions of TinyMCE, the open source AJAX tool used by countless websites to provide rich text editing. If you see a row of Office-like formatting icon buttons, that's TinyMCE in action; in Firefox 11, you often see a blank window rather than your contents -- that's the bug.

Relax, the contents are still there, but you need to disable TinyMCE to get to them, often via a control to switch to HTML editing or to disable rich text formatting in many Web pages.

At Mozilla's help forums, the suggested fix is to update TinyMCE to the most recent version. That advice shows the self-destruction in play with Mozilla's strategy. Firefox is a Web browser, and by its very nature the Web is a heterogeneous, uncontrolled collection of resources. Expecting every website that uses TinyMCE to update it whenever an incremental rev comes out is silly and unrealistic, and certainly not just because Mozilla decided compatibility in its parade of new Firefox releases was everyone else's problem. The Web must handle such variablility -- especially the browsers used to access it.

Internet Explorer, Chrome, and Safari all work fine, by the way, with the TinyMCE versions Firefox 11 can't handle. Maybe Firefox 12 will fix the bug, but in the meantime, users whose websites were perfectly usable are stuck with them not working for no apparent reason. Additionally, Mozilla offers no rollback capability to previous versions. The TinyMCE example is just that -- an example. Firefox 10 (and 11) no longer works with my company's Java-based time sheet app, returning Java server error messages when I try to enter information for any date. No other browser breaks on that app, either. There are yet more examples in the Mozilla support forums.

Firefox used to be rock-solid. No longer.

As a Mac user, I used OS X's Time Machine utility to restore Firefox 9, which solved both the TinyMCE issue and the Java app problem, then I disabled Firefox's update facility. But most users have no such convenient way to roll back to a previous version. Their only real choice is to change to a different browser. I'm certainly at that point, as soon as I find a plug-in for Safari or Chrome that gives me a permanent side panel for my bookmarks (IE also has such a side panel, but it is not available for OS X), the one reason I have left to stick with Firefox -- Firefox 9, that is.

This story, "Firefox: In with the new, out with the compatibility," was originally published at InfoWorld.com. Get the first word on what the important tech news really means with the InfoWorld Tech Watch blog. For the latest developments in business technology news, follow InfoWorld.com on Twitter.

From CIO: 8 Free Online Courses to Grow Your Tech Skills
Join the discussion
Be the first to comment on this article. Our Commenting Policies