Cisco releases security patches for Unified Communications Manager

Company addressed some -- but not all -- of the vulnerabilities used in a publicly demonstrated attack

Cisco Systems released a security patch for its Unified Communications Manager (Unified CM) enterprise telephony product in order to mitigate an attack that could allow hackers to take full control of the systems. The company also patched denial-of-service vulnerabilities in its Intrusion Prevention System software.

The Cisco Unified CM is a call-processing component that extends enterprise telephony features and functions to IP phones, media-processing devices, VoIP gateways, and multimedia applications, according to Cisco.

[ Stay ahead of the key tech business news with InfoWorld's Today's Headlines: First Look newsletter. ]

At the beginning of June, researchers from a French security consultancy firm called Lexfo publicly demonstrated an attack that chained together multiple "blind" SQL injection, command injection, and privilege escalation vulnerabilities in order to compromise a Cisco Unified CM server.

The demonstration also revealed that all versions of Cisco Unified CM use a static hard-coded encryption key to encrypt sensitive data stored in the server's database, including user credentials.

"The initial blind SQL injection allows an unauthenticated, remote attacker to use the hard-coded encryption key to obtain and decrypt a local user account. This allows for a subsequent, authenticated blind SQL injection," Cisco said Wednesday in a security advisory.

"Successful exploitation of the command injection and privilege escalation vulnerabilities could allow an authenticated, remote attacker to execute arbitrary commands on the underlying operating system with elevated privileges," the company said.

Cisco has released a security patch in the form of a Cisco Options Package (COP) called cmterm-CSCuh01051-2.cop.sgn that addresses some of the vulnerabilities used in the attack, including the one allowing the initial blind SQL injection.

Customers can download the file from Cisco's website and install it as a temporary solution until the company releases new and patched versions of the Unified CM software.

The COP file mitigates the initial attack vector and reduces the documented attack surface, Cisco said. However, some other vulnerabilities used in the attack remain unpatched.

The remaining vulnerabilities are still being investigated and no workarounds are available for them yet, the company said.

Versions 7.1.x, 8.5.x, 8.6.x, 9.0.x, and 9.1.x of the Cisco Unified CM are affected by the publicly demonstrated attack. Version 8.0 is also affected, but is no longer supported. Customers using this version are advised to contact Cisco for assistance in upgrading to a supported version.

The company is also investigating the possibility that some of its other voice products are affected by one or more of the individual vulnerabilities used in the attack. These products are the Cisco Emergency Responder, Cisco Unified Contact Center Express, Cisco Unified Customer Voice Portal, Cisco Unified Presence Server/Cisco IM and Presence Service and Cisco Unity Connection.

On Wednesday, Cisco also advised customers about several denial-of-service vulnerabilities affecting the software running on some of its Intrusion Prevention System (IPS) products.

Products affected by one or several of those vulnerabilities are the Cisco ASA 5500-X Series IPS Security Services Processor (IPS SSP) software and hardware modules; Cisco IPS 4500 Series Sensors; Cisco IPS 4300 Series Sensors; the Cisco IPS Network Module Enhanced (NME) and the Cisco Catalyst 6500 Series Intrusion Detection System (IDSM-2) Module.

The company has released patched versions of the Cisco IPS Software for those products, except for the Cisco IDSM-2. A workaround for the vulnerability affecting Cisco IDSM-2 was made available.

Mobile Security Insider: iOS vs. Android vs. BlackBerry vs. Windows Phone
Recommended
Join the discussion
Be the first to comment on this article. Our Commenting Policies